Major Outage Affecting Multiple Truckin Digital Services
Incident Report for Truckin Digital Status
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 08:32 EDT
Investigating
We are currently investigating a global issue related to Trimble PC MILER Web Services and AWS affecting Truckin Digital communications. Users may experience difficulties with accessing services and maintaining connections. Our teams are working diligently to resolve the cause and implement a solution as quickly as possible.
Posted Jul 19, 2024 - 04:14 EDT
This incident affected: Connected Services, System Services, and GPS Updates.